Support Us

CKAN 2.6.0 released, patch versions for 2.3.x, 2.4.x and 2.5.x available

November 2, 2016 in Releases

We are happy to announce that CKAN 2.6.0 is now released. In addition, new patch releases for older versions of CKAN are now available to download and install.

CKAN 2.6

The 2.6.0 release includes improvements on how private datasets are shown on search results, as well as several other minor improvements and over 50 bug fixes. You can check all individual changes on the CHANGELOG. Thank you very much to all the almost 30 community members that have submitted patches since the last release.

If you have customizations or extensions, we suggest you trial the upgrade first in a test environment and refer to the changes in the changelog. Upgrade instructions are below. As there aren’t many major changes since the last version upgrading should be relatively straight-forward.

Note that as previously announced, starting from this version, CKAN requires at least Python 2.7 and Postgres 9.2.

CKAN patch releases

These new patch releases for CKAN 2.3.x, 2.4.x and 2.5.x (2.3.5, 2.4.4 and 2.5.3) fix important bugs and security issues, so users are strongly encouraged to upgrade to the latest patch release for the CKAN version they are using.

For a list of the fixes included you can check the CHANGELOG.

Upgrading

For details on how to upgrade, see the following links depending on your install method: Upgrading CKAN.

If you find any issue, you can let the technical team know in the mailing list or the IRC channel.

 

Comments are closed.